Trading conditions for metals and indexes

12 January, 2018

Trading conditions for metals and indexes

We are glad to announce that starting from 15.01.2018 the price accuracy for the following contract groups will be increased.

Please take information into account during the planning of your trading in the financial markets.

More detailed information concerning the trading conditions we offer can be found in «Contract specification» section.

Starting from 15.01.2018 the floating spread mode will be set for «Indexes» group of contracts as well.


Source link  
FortFS: the results of 2017

The year 2017 is over and, as usual, we sum up all achievements of the FortFS team got during the last year. 2017 was productive and brought new...

Cryptocurrencies leverage change

We would like to inform you that in accordance to our liquidity providers demand starting from 12.01.2018 the leverage for the cryptocurrencies...

Crypto currencies trading is launched

Meet the most popular crypto-currencies in the terminal Fort Financial Services. Crypto currency is the most progressive financial instrument...


Windows 10 update

On October 17, Microsoft officially released a major update of the operating system Windows 10 Fall Creators Update. This update affects configurations and encryption keys...

Spreads on popular contracts reduced

Dear traders and partners, FortFS announces a new reduction in spreads! From 02.10.2017 the 4 most popular contracts spreads will be...

FortFS CopyTrading automatic service

CopyTrading is the automatic service to copy trades from selected trader’s accounts. This service allows you to choose the most successful...


Swap changes for FOREX instruments

We'd like to inform you that new swap rates come into effect starting from 26-th of July for all FOREX instruments. More detailed information

Change of conditions for CFD Metals

Starting from 10th of July new trading conditions for the CFD Metals contracts group take effect. You can have a closer look at new conditions...

Windows XP will no longer be supported

Windows XP/2003/Vista will no longer be supported by all modules of the MetaTrader 4 platform...

  


Share: